78 with loose sway in rear



78 with loose sway in rear

Postby grumpyvette » August 12th, 2010, 2:52 pm

" i have a 78 L82 four speed that i have owned since 95, my problem is when i run around 60 or 70 if i make a quick serve the rear end starts swaying , would this be the mono spring thanks for any help"

its much more likely you need new shocks and new poly bushings, check your tires and air pressure first,then anytime you have a suspension issue the first thing you want to do is put the car up on a lift and do a quick visual inspection, looking for obvious worn or broken components , like shocks, bushings,u-joints, wheel bearings etc. and inspect the tires for wear , and spin the tires and listen closely for indications the brakes or bearings need to be carefully inspected further after a partial dis-assembly that may indicate the potential source of your problem.
locating small maintenance issues before they become potential parts failures saves you a great deal of time and money.
take it out for a road test after swapping the tires side to side to see if it results in a change., if you still don,t locate the problem have a local shop inspect and align the car

http://www.summitracing.com/parts/ENS-3 ... refilter=1

http://www.summitracing.com/parts/ENS-3-4126G/

http://www.summitracing.com/parts/BSN-F ... refilter=1
IF YOU CAN,T SMOKE THE TIRES AT WILL,FROM A 60 MPH ROLLING START YOUR ENGINE NEEDS MORE WORK!!"!
IF YOU CAN , YOU NEED BETTER TIRES AND YOUR SUSPENSION NEEDS MORE WORK!!
grumpyvette

User avatar
Site Admin
Site Admin
 
Posts: 14105
Joined: September 14th, 2008, 1:40 pm
Location: florida

Return to Suspension and Brakes: Repairs and Modifications

Who is online

Users browsing this forum: No registered users and 1 guest

cron