replacing the oil pressure sending unit



replacing the oil pressure sending unit

Postby grumpyvette » March 16th, 2009, 11:13 am

viewtopic.php?f=38&t=446&p=550&hilit=+pressure+sensor#p550

this socket helps
http://www.sjdiscounttools.com/kdt2569.html

http://store.summitracing.com/egnsearch ... toview=sku

viewtopic.php?f=80&t=728

Image

viewtopic.php?f=32&t=162
Image

the oil pressure sending unit on most gen I and -gen II chevy engines is located near the upper rear engine where the distributor is located on the first gen engines.

theres lots of guys that spend days trying to stop leaks the the threads or connection plumbing on those sensors all to no gain, simply because its RARELY the threads that leak, its commonly the sending unit itself that defective and leaking internally,or externally, swap it out and when you install the new version coat the threads lightly with high temp silicone




read thru these links

viewtopic.php?f=54&t=3536

viewtopic.php?f=54&t=2187

viewtopic.php?f=54&t=117

viewtopic.php?f=54&t=3834

viewtopic.php?f=54&t=296



pressure is the MEASURE of resistance to FLOW, ID suggest checking the pressure with a different gauge BEFORE going any further as thats most likely a defective gauge or sensor
the oil temp sensor is located in the main oil feed from the filter in the block,
Image

Id be looking to replace the sensor, if your having odd pressure readings as they go defective frequently,then theres also the connecting wire or gauge, oil temps especially if the engine maintains fairly consistent oil pressure and flow rates, the oil pressure sensors up near the distributor. Id suggest verifying the oil level and pressure, it should be about 205F-225F at operational temps at idle and pressure should be no lower than 10 psi per 1000rpm, or higher than about 30 psi at idle with a 10w 30 or 10-w 40 oil, the bye pass should limit pressure to about 65psi, its more than likely a defective sensor or gauge

viewtopic.php?f=80&t=728&p=9217&hilit=temp.sensor#p9217
IF YOU CAN,T SMOKE THE TIRES AT WILL,FROM A 60 MPH ROLLING START YOUR ENGINE NEEDS MORE WORK!!"!
IF YOU CAN , YOU NEED BETTER TIRES AND YOUR SUSPENSION NEEDS MORE WORK!!
grumpyvette

User avatar
Site Admin
Site Admin
 
Posts: 14105
Joined: September 14th, 2008, 1:40 pm
Location: florida

Re: replacing the oil pressure sending unit

Postby grumpyvette » March 26th, 2009, 12:28 pm

any time your having a oil pressure problem think about this

step one ,verify the gauge and sending unit are accurate and your having a oil pressure problem using a different test gauge,

now this might not be the cause in your case but its VERY common for guys to swap in a new high volume oil pump and not realize that high volume means the pump gears are longer and that requires a longer /deeper oil pump body that places the oil pump pick-up closer to the oil pan floor, if they did that (ESPECIALLY with out checking clearances or brazing the oil pump pick-up to maintain a 3/8"-`1/2" clearance with the oil pan floor) the oil flow into the pump gets restricted. at idle pressure fine, but as soon as the rpms build the restriction limits oil flow into the pump and pressure drops off, adding a qt of extra oil changes nothing, this is the source of the MYTH that high volume oil pumps pump the oil pan dry, but in truth there's plenty of oil its just not allowed to flow into the pump due too clearance issues, the cure is brazing the oil pump pick-up for the necessary 1/2" oil pan floor clearance AFTER carefully measuring , with modeling clay, to make sure its maintained with the oil pan in place, many guys braze a spare 3/8 NC nut to the edge of the oil pump pick-up so it CAN,T get closer than 1/2" from the oil pan floor

if you have a constant oil leak from the upper rear engine near the distributor area,its a safe bet its the oil pressure sensor, or fuel pump switch or the connections to the block,or the intake rear seal, replace the sensors, if that does not cure it the intake gasket most likely needs to be replaced.

http://www.ecklers.com/search.asp?action=freeSearch&free_text=oil%20pressure%20sensor&yearConstraint=1985&searchHistory=

The single wire unit is for the oil pressure gauge
Image
Image
and the 2 wire unit is the switch that operates the fuel pump.


Oil temp sender is on side of block above oil filter
Image


http://www.digitalcorvettes.com/forums/showthread.php?t=89593

http://forum.grumpysperformance.com/viewtopic.php?f=32&t=36

viewtopic.php?f=54&t=1396

Image
IF YOU CAN,T SMOKE THE TIRES AT WILL,FROM A 60 MPH ROLLING START YOUR ENGINE NEEDS MORE WORK!!"!
IF YOU CAN , YOU NEED BETTER TIRES AND YOUR SUSPENSION NEEDS MORE WORK!!
grumpyvette

User avatar
Site Admin
Site Admin
 
Posts: 14105
Joined: September 14th, 2008, 1:40 pm
Location: florida


Return to Oil and Lube Systems

Who is online

Users browsing this forum: No registered users and 4 guests

cron