Now it has a erratic idle



Now it has a erratic idle

Postby grumpyvette » February 5th, 2015, 11:17 am

TexasDan wrote:I got my 82 back from the repair shop. Drove good for about 2 weeks. Now it has a erratic idle. When cold the engine idles around 1400 rpm, when giving it gas the engine seems to stumble then takes off, then stumbles and goes. It's noticeable when driving. Once the motor is warmed up the idle is around 500 rpm but it acts like it misses, then idles up to 700 rpm. This when in gear. When driving on freeway runs fine but when in stop and go traffic it acts like it's about to shut off, it did one time, but if you give it gas it stumbles then goes.

Both iac's have been changed. New plugs, dist cap, wires, fuel filter, pump and the CO2 sensor.

I'm thinking vaccume lines or intake leak. I found one vaccume line that was not even hooked up from the repair shop. Plugged it and that's when the latest issues started.

About ready to switch to TPI.




http://forum.grumpysperformance.com/viewtopic.php?f=32&t=10096&p=39710&hilit=cross+fire+balance#p39710

viewtopic.php?f=44&t=882&p=45944&hilit=+propane+torch+leaks#p45944

viewtopic.php?f=32&t=303&p=368&hilit=shop+manual#p368

perhaps a bit of related info
IF YOU CAN,T SMOKE THE TIRES AT WILL,FROM A 60 MPH ROLLING START YOUR ENGINE NEEDS MORE WORK!!"!
IF YOU CAN , YOU NEED BETTER TIRES AND YOUR SUSPENSION NEEDS MORE WORK!!
grumpyvette

User avatar
Site Admin
Site Admin
 
Posts: 14105
Joined: September 14th, 2008, 1:40 pm
Location: florida

Return to corvette related misc.

Who is online

Users browsing this forum: No registered users and 1 guest

cron